INFO.lesbarques.fr

upgrade php4 et mysql sur sme

lundi 5 mai 2008 par Georges Charpenay

ATTENTION :

J’ai utilisé la méthode ci-dessous pour upgrader mysql et php5, elle fonctionne, cependant vous arrivez à l’erreur 500 avec impossibilité d’accéder au server-manager. Elle a l’avantage de faire prendre de l’avance au système en terme de performances, mais elle lie le système à php5 et nous ne sommes pas à l’abri de ce genre de problème.

Je la publie quand même et je modifierai cet article dès que je l’aurais corrigé Si quelqu’un connait la suite, merci de contribuer en répondant à cet article.

J’ai trouvé cependant une autre alternative qui permet de conserver le php4 pour le système et d’installer en parallèle PHP5 qu’on lancera indépendamment pour les applications de votre choix qui le requièrent. Ce qui permet d’avoir de laisser aux mises à jour le choix de basculer au niveau système sur php5 dès que les applicatifs système la réclameront, c’est à dire par les mises à jour système. Ce qui permet de travailler en php5 sans toucher la configuration système. Je vais la tester très vite et je publierais un article dès qu’elle sera fonctionnelle.

METHODE : TOUT EN PHP5 (OS COMPRIS)

Pour upgrader mysql et php, par exemple pour installer egroupware 14, qui demande du php5, il faut utiliser yum pour effectuer la mise à jour.

Mais avant certaines dépendances liées à PHP4 doivents être supprimées, comme par exemple eaccelerator.

rpm -e - -nodeps smeserver-eaccelerator

(attention, ce site est fait sous spip et les deux tirets "- -" avant "nodeps" sont contigus, se suivent -mauvais formatage de spip à l’édition-)

Si le paquet n’est pas installé, vous pouvez passer à la suite, mais s’il a été trouvé et désinstallé, il faut aller, par précaution, détruire le dossier /var/cache/ eaccelerator .

Idem ensuite pour PostGreSQL pour pouvoir le réinstaller proprement après PHP5.

rpm -e postgresql Ainsi que ses dépendances si elles n’ont pas été supprimée : rpm -e postgresql-python rpm -e postgresql-server rpm -e postgresql-contrib rpm -e postgresql-libs rpm -e postgresql-devel rpm -e postgresql-jdbc rpm -e postgresql-libs rpm -e php-pgsql

Ensuite on peut procéder à l’installation de PHP5 :

yum - -enablerepo=centosplus update php

(attention, ce site est fait sous spip et les deux tirets "- -" avant "enablerepo" sont contigus, se suivent -mauvais formatage de spip à l’édition")

Pour MySQL5 :

yum - -enablerepo=centosplus update mysql

On finit l’install et on redémarre ensuite le serveur avec :

signal-event post-upgrade ; signal-event reboot

Pour qu’Apache puisse prendre en compte les modifications, il faut, dans le fichier /etc/httpd/conf/httpd.conf remplacer la ligne, LoadModule php4_module modules/libphp4.so par LoadModule php5_module modules/libphp5.so

En principe, il s’agit d’une simple vérification, pour ma part, la ligne a été modifiée directement dans les templates et httpd.conf a été regénéré.

Puis on relance Apache : httpd -k restart

PHP 5 est alors installé.

Reste plus qu’à installer Postgresql... Pour finir dans les mises à jour, vous pouvez toujours installer phpmyadmin 2.11 (au préalable yum remove —ancien paquet de phpmyadmin—)


phpmyadmin 2.11

Accueil du site | Contact | Plan du site | Espace privé | visites : 511986

Site réalisé avec Spip + Squelette Alternatives

RSSfr

Creative Commons License